Back

Invoices Disruption

February 3, 2026 at 12:36 PM EST Resolved after 8m

Updates

Resolved

The disruption that some users may have experienced affecting Invoices has been resolved. Our team will continue to monitor the situation to ensure stability. Thank you for your patience, and we apologize for any inconvenience caused.

February 3, 2026 at 12:45 PM EST
Monitoring

Our engineers have identified the cause of the issue affecting Invoices and are implementing a fix. Some users may begin to see improvements as we roll out the resolution. Thank you for your patience, and we appreciate your understanding.

February 3, 2026 at 12:44 PM EST
Investigating

We are aware of an issue where invoice links are not being sent, which may be impacting some users. Our engineering team is actively investigating and working to resolve the disruption. Thank you for your patience as we work to restore normal service.

February 3, 2026 at 12:36 PM EST