Back

Appointment Update Errors for Rooms & Resources Businesses

March 16, 2026 at 01:37 PM EDT Resolved after 1h 23m

Updates

Resolved

The disruption that some users may have experienced affecting Rooms & Resources has been resolved. Our team will continue to monitor the situation to ensure stability. Thank you for your patience, and we apologize for any inconvenience caused.

March 16, 2026 at 03:01 PM EDT
Monitoring

Businesses that are under the Rooms and Resources program might experience rejections when attempting to update an appointment because of an internal error in the system. We have identified, implemented, and are now monitoring our fix for this.

March 16, 2026 at 02:53 PM EDT
Investigating

Businesses that are under the Rooms and Resources program might experience rejections when attempting to update an appointment because of an internal error in the system. We have identified the issue and are in the process of deploying the mitigation.

March 16, 2026 at 01:37 PM EDT